|Check Point Reference:||CPAI-2015-0223|
|Date Published:||4 Mar 2015|
|Last Updated:||Sunday 03 December, 2017|
|Protection Provided by:||
|Who is Vulnerable?||OpenSSL before 0.9.8zd, 1.0.0 before 1.0.0p, and 1.0.1 before 1.0.1k|
|Vulnerability Description||A vulnerability has been detected in the way OpenSSL handles TLS handshakes that use weak, legacy cipher suites. An attacker might leverage this vulnerability to intercept secure communications.|
This protection may be used to prevent attacks exploiting the FREAK vulnerability.
In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.
This protection's log will contain the following information:
Attack Name: SSL Enforcement Violation.
Attack Information: OpenSSL TLS Export Cipher Suite Downgrade