|Check Point Reference:||CPAI-2022-1727|
|Date Published:||5 Sep 2023|
|Last Updated:||Tuesday 05 September, 2023|
|Protection Provided by:||
|Who is Vulnerable?|| Linux Kernel 4.8 and later, prior to 4.9.301|
Linux Kernel 4.10 and later, prior to 4.14.266
Linux Kernel 4.15 and later, prior to 4.19.229
Linux Kernel 4.20 and later, prior to 5.4.179
Linux Kernel 5.5 and later, prior to 5.10.100
Linux Kernel 5.11 and later, prior to 5.15.23
Linux Kernel 5.16 and later, prior to 5.16.9
Linux Kernel 5.17 -
Linux Kernel 5.17 Release Candidate 1
Linux Kernel 5.17 Release Candidate 2
Linux Kernel 5.17 Release Candidate 3
|Vulnerability Description||A buffer overflow vulnerability exists in Linux Kernel. Successful exploitation of this vulnerability could allow a remote attacker to execute arbitrary code on the affected system or cause application crashes.|
This protection detects attempts to exploit this vulnerability.
In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.
This protection's log will contain the following information:
Attack Name: Content Protection Violation.
Attack Information: Linux Kernel Buffer Overflow (CVE-2022-0435)